Symptom:
You are attempting to synchronize your Act! contacts and/or calendar with Outlook and synchronization fails. In the Windows Event Viewer and the Act! Integration history (Sage ACT! 2013 and higher), you see the error:
"Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass' to interface type 'Microsoft.Office.Interop.Outlook._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{00063001-0000-0000-C000-000000000046}' failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))."
Products:
Family: Act!
Products: Act! Pro, Act! Premium
Environment:
Third-Party: Microsoft Outlook 2007, 2010, 2013
Cause:
This issue can be caused by attempting to integrate Act! with a version of Microsoft Outlook that was installed using Click-to-Run (Act! v18 or earlier), or by a left over registry key if you have downgraded your version of Microsoft Office from a newer version to an older version.
Solution:
Attempting to use Act! with Outlook Click-to-Run in Act! versions v18 and earlier
Click-to-Run versions of Office are not supported by Act! versions prior to v19. For more information, refer to the following knowledgebase article:
Supported Versions of Microsoft® Office by Version of Act!
Answer ID Supported Versions of Microsoft® Office by Version of Act!
Office was downgraded from a newer version to an older version
This issue can be resolved by deleting an invalid registry key left over from the higher version of Office. Follow the steps below that pertain to your scenario:
If you downgraded from Office 2010 to Office 2007
If you downgraded from Office 2013 to Office 2010 or 2007
If you downgraded from Office 2016 to Office 2013, 2010, or 2007
Related Information:
In Sage ACT! 2013, the ability to view Outlook synchronization history and errors was added. See this Knowledgebase article for instructions to use this feature:
You are attempting to synchronize your Act! contacts and/or calendar with Outlook and synchronization fails. In the Windows Event Viewer and the Act! Integration history (Sage ACT! 2013 and higher), you see the error:
"Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass' to interface type 'Microsoft.Office.Interop.Outlook._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{00063001-0000-0000-C000-000000000046}' failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))."
Products:
Family: Act!
Products: Act! Pro, Act! Premium
Environment:
Third-Party: Microsoft Outlook 2007, 2010, 2013
Cause:
This issue can be caused by attempting to integrate Act! with a version of Microsoft Outlook that was installed using Click-to-Run (Act! v18 or earlier), or by a left over registry key if you have downgraded your version of Microsoft Office from a newer version to an older version.
Solution:
Attempting to use Act! with Outlook Click-to-Run in Act! versions v18 and earlier
Click-to-Run versions of Office are not supported by Act! versions prior to v19. For more information, refer to the following knowledgebase article:
Supported Versions of Microsoft® Office by Version of Act!
Answer ID Supported Versions of Microsoft® Office by Version of Act!
Office was downgraded from a newer version to an older version
This issue can be resolved by deleting an invalid registry key left over from the higher version of Office. Follow the steps below that pertain to your scenario:
If you downgraded from Office 2010 to Office 2007
- Close Sage ACT! and all Office applications (Outlook, Word, Excel®).
- Click your Windows® Start button, either click Run or go to the Search box on the Start Menu, and type regedit. The Windows registry editor opens.
- Navigate to the following key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.4
- Delete the 9.4 key.
- Close the registry editor.
- Reopen Act!, reopen Outlook, and perform a contact and/or calendar synchronization to test.
If you downgraded from Office 2013 to Office 2010 or 2007
- Close Act! and all Office applications (Outlook, Word, Excel®).
- Click your Windows Start button, either click Run or go to the Search box on the Start Menu, and type regedit. The Windows registry editor opens.
- Navigate to the following key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.5
- Delete the 9.5 key.
- Close the registry editor.
- Reopen Act!, reopen Outlook, and perform a contact and/or calendar synchronization to test.
If you downgraded from Office 2016 to Office 2013, 2010, or 2007
- Close Act! and all Office applications (Outlook, Word, Excel®).
- Click your Windows Start button, either click Run or go to the Search box on the Start Menu, and type regedit. The Windows registry editor opens.
- Navigate to the following key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.6
- Delete the 9.6 key.
- Close the registry editor.
- Reopen Act!, reopen Outlook, and perform a contact and/or calendar synchronization to test.
Related Information:
In Sage ACT! 2013, the ability to view Outlook synchronization history and errors was added. See this Knowledgebase article for instructions to use this feature:
How do I view contact and calendar synchronization history for Act! integration with Microsoft Outlook or Google?
Answer ID: How do I view contact and calendar synchronization history for Act! integration with Microsoft Outlook or Google?
Answer ID: How do I view contact and calendar synchronization history for Act! integration with Microsoft Outlook or Google?