Symptom:
I have just unpacked and restored a remote database and am trying to synchronize it for the first time but I am getting the Error: “Failed to setup remote sync entity. Main database is inactive for sync.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2013 and later
Cause:
This error can occur if the Act! installation on the computer you are initiating synchronization from has not been registered, or if synchronization is enabled on the server, but Accept Incoming Syncs is grayed out specifically for that database and cannot be enabled.
Solution:
Remote database is not registered
- Register your Act! installation on the remote database computer using the steps in the following knowledgebase article:
How to register and activate Act! versions 2009 (11.0) and later
Answer ID How to register and activate Act! versions 2009 (11.0) and later
- Attempt to synchronize again
Accept Incoming Syncs is grayed out on the server
WARNING: The following steps will completely disable the synchronization of all remotes and they will need to be recreated. If you have remotes that are currently synchronizing without any issues, make sure to synchronize them and discontinue their use before proceeding with the following steps.
Note: If you are using Act! Premium Cloud, it will be necessary to contact support for assistance in resolving this issue if registering the Act! installation was unsuccessful.
- On the server, click Tools > Synchronize Database > Synchronization Panel
- In the Synchronization Panel, click Manage Database
- Disable any active remote databases. For information on how to disable remote databases, refer to the following knowledgebase article:
How to manage remote databases in Act!
Answer ID How to Manage Remote Databases in Act!
- After disabling the active remote databases, click Home
- Click Disable Synchronization and click Yes when prompted
- Click Enable Synchronization and click Yes when prompted
- Click Close
- Click Tools > Synchronize Database > Accept Incoming Syncs
- Click OK
- Click Tools > Synchronize database > Synchronization Panel
- Create new databases for each remote that was disabled. For information on how to create a remote database, refer to the following knowledgebase article:
How do I set up remote database synchronization in Act!?
Answer ID How do I set up remote database synchronization in Act!?
- Unpack the remote database to the remote computer and attempt to synchronize again to test