Symptom: I am receiving the Error: "Act.Outlook.Service has stopped working" randomly throughout my work day, even when not doing anything in Act!
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: v16 and later
Environment:
Third Party: Microsoft Outlook
Cause:
This can occur if the Act.Outlook.Service.exe is running in the background and the HistoryQueue has multiple emails that it is trying to attach that is causing the service to crash.
Solution:
Clearing up the History Queue
Running Act.Outlook.Service.exe in compatibility mode (Windows 10 only)
If you are using Windows 10 and the above steps did not resolve the issue, you may be able to resolve the issue by configuring Act.Outlook.Service.exe to run in Compatibility Mode for Windows 7
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: v16 and later
Environment:
Third Party: Microsoft Outlook
Cause:
This can occur if the Act.Outlook.Service.exe is running in the background and the HistoryQueue has multiple emails that it is trying to attach that is causing the service to crash.
Solution:
Clearing up the History Queue
- Clear up the History Queue by following the steps in the "History Queue Folder" section of the following knowledgebase article:
No history created or recorded in Act! versions 2011 (v13) through v20.0 when sending e-mail from Microsoft Outlook 2003 and later
- Test using the computer
Running Act.Outlook.Service.exe in compatibility mode (Windows 10 only)
If you are using Windows 10 and the above steps did not resolve the issue, you may be able to resolve the issue by configuring Act.Outlook.Service.exe to run in Compatibility Mode for Windows 7
- Browse to C:\Program Files (x86)\ACT\Act for Windows
Note: If you're on a 32-bit machine, change Program files (x86) to Program Files in the path listed above
- Right click Act.Outlook.Service.exe and select Properties
- Select the Compatibility tab
- Check the box for Run this program in compatibility mode
- From the drop-down menu select Windows 7
- Click Apply, then OK
- Double click Act.Outlook.Service.exe to start the Service
- Send an email to test History is recorded, and test using the computer to see if the error appears again