Symptom:
My Act! icons are missing from Microsoft Outlook.
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2006 (v8) through v21
Environment:
Third Party: Microsoft Outlook
Cause:
This issue can occur for multiple reasons:
- You are using a version of Outlook which is not compatible with your version of Act!
- Outlook email preferences have not been configured
- Outlook email preferences were configured using a .PAD file that is not stored locally
- Your Act! preferences are damaged
- Windows User Account Control Settings (UAC) are blocking the Act! add-in from loading (Windows Vista and later only)
- Outlook was installed after Act!
- Windows file permissions blocked installation of Act! address book provider information
- The Act! address book was not properly added to Outlook
- The Act! add-in is disabled or not configured to load in Outlook
- The Act! add-in is being blocked by Outlook Macro Security
- Internet Zone setting for Outlook 2003 (v16 and earlier only)
- Corrupted Outlook toolbar customizations
- The Act! add-in is being blocked by a Third-Party Add-In
- Windows Registry settings for Act! add-in load behavior
- The Act! address book was not properly added to the Windows Registry
- The Act! plug-in files are damaged
- Damaged Act! add-in Windows Registry entries
- Damaged Microsoft Outlook Application (Outlook 2007 and earlier only)
Solution:
Refer to each section below, in order, to troubleshoot this issue:
You are using a version of Outlook which is not compatible with your version of Act!
If you are using a version of Outlook which is not compatible with your version of Act!, the Act! icons are most likely to not be available. To determine whether your version of Outlook is compatible with your version of Act!, refer to the following knowledgebase article:
Supported Versions of Microsoft® Office by Version of Act!
Answer ID Supported Versions of Microsoft® Office by Version of Act!
If you are using a supported version of Outlook, proceed to the next section
Return to Top
Outlook email preferences have not been configured
Outlook email preferences must be configured prior to the Act! add-ins becoming available in Outlook. Follow the steps below:
- Close Outlook and make sure that Act! is open
- Configure Outlook email preferences. For information, refer to the following knowledgebase article:
How to configure Microsoft Outlook as your e-mail client in Act! versions 2011 and higher
Answer ID How to use Microsoft Outlook as your e-mail client in Act! versions 2011 and higher - Launch Outlook and verify that the Add-ins are available. If still unavailable, proceed to the next section
Outlook email preferences were configured using a .PAD file that is not stored locally
This can occur if the .PAD file you selected when you configured your Outlook email preferences was stored in a network location rather than locally to the computer you are using. If the .PAD file is not local, an interruption in your network connection can cause your computer to lose the path to the .PAD file, thus removing the address book and resulting in having to manually add the address book again. To resolve this:
- Make a copy of the database .PAD file that resides in the network location
- Move the copy of the database .PAD file to the computer having the issue
- Reconfigure your Outlook email preferences with the new local copy of the database .PAD file
- Test to see if the icons are present
Your Act! preferences are damaged
This can also occur if your Act! preferences are damaged. This is more likely to be the case if you have upgraded to a newer version of Act! from an older version of Act!
- Rebuild the Act! Preferences by following the instructions in the following knowledgebase article:
How to rebuild the Act! Preferences file - Reconfigure your Outlook Integration preferences, then check to see if the icons are present
Windows User Account Control Settings (UAC) are interfering with loading the add-ins (Windows Vista and later only)
Option 1: Run Act! and Outlook as an administrator
You may be able to workaround the UAC settings by running Act! and Outlook as an administrator
- Close Act! and Outlook, then navigate to your desktop
- Right-click the Act! icon, then choose Run as administrator
- If prompted, click Allow
- Once Act! has opened, minimize the window and navigate to the desktop again
- Right-click the Outlook icon, then choose Run as administrator
- If prompted, click Allow
- Verify whether the add-ins are available
Note: The issue can also occur if Act! is set to run as an administrator but Outlook is not or vice versa. To check this, individually right-click each program’s shortcut, choose properties, then navigate to the Compatibility tab and ensure that the Privelege level settings match each other for both programs.
Option 2: Disable UAC
Note: This information is provided as a convenience. Swiftpage does not provide support for Microsoft products. For assistance with configuring or disabling UAC, contact Microsoft.
If running the programs as an Administrator is unsuccessful, you may need to disable UAC. For more information about UAC and how to disable it, refer to the following Microsoft documentation:
User Account Control Step-by-Step Guide
Return to Top
Outlook was installed after Act!
In order for Act! and Outlook to properly integrate with each other, Outlook must be installed prior to Act!. The same applies to updates which are applied to Outlook while act! is installed (For example, upgrading from Outlook 2013 to Outlook 2016 while Act! is installed). If you installed Outlook after Act! was already installed on the computer, or if you upgraded your version of Outlook while Act! was installed follow the steps below:
Recreate the Act! Outlook Addin registry keys
- Close Act! and Outlook
- Follow the steps in the following knowledgebase article:
How do I rebuild the registry keys for the Act! Outlook Addins?
Answer ID How do I rebuild the registry keys for the Act! Outlook Addins? - Reconfigure your email preferences
- Open Outlook and verify that the Act! icons are available. If still unavailable, it may be necessary to uninstall and reinstall Act!.
Uninstall and Reinstall Act!
Note: If you are not entirely sure whether Act! was installed before or after Outlook, you may be able to avoid uninstalling and reinstalling Act! by following the rest of the steps in the article before following the steps to uninstall and reinstall Act!. If you are certain that Act! was installed before Outlook, proceed with the steps below.
- Uninstall Act!. For information on uninstalling Act!, refer to the following knowledgebase article:
How do I uninstall Act!?
Answer ID How do I uninstall Act!? - Reinstall Act!. For information on installing Act!, refer to the following knowledgebase article:
How do I install Act!?
Answer ID How do I install Act!? - Configure Outlook Email preferences
- Verify that the Add-ins are available. If still unavailable, proceed to the next section
Windows file permissions blocked installation of Act! address book provider information
Note: This information is provided as a convenience. Swiftpage does not provide support for Windows file permissions. For additional assistance with file permissions, contact Microsoft.
- Close out of Act! and Outlook
- Open Windows Explorer, then browse to C:\Users\[Windows Username]\AppData\Local\Microsoft\Outlook
- Locate and right click mapisvc.inf, then choose Properties
- Click the Security tab, then click the Edit… button
- In the Permissions window, click Add…
- Type Everyone into the available field, then click OK
- Under Permissions for Everyone, check the Allow option for Full control, then click OK
- Click OK again to close out of the properties
- Browse to the Act! program folder. By default, it is located in one of the following locations, depending on your operating system type and version of Act!
64-bit Operating System:
Act! Pro or Act! Premium: C:\Program Files (x86)\ACT\Act for Windows
Act! Premium (access via web): C:\Program Files (x86)\ACT\Act for Web
32-bit Operating System:
Act! Pro or Act! Premium: C:\Program Files\ACT\Act for Windows
Act! Premium (access via web): C:\Program Files\ACT\Act for Web - Locate and double-click Act.Outlook.Repair.exe
- Once the repair completes and the command window disappears, launch Act! and Outlook and verify that the icons are there.
The Act! address book was not properly added to Outlook
This can occur if the Act! address book was not properly added to Outlook during the configuration of the preferences.
- Depending on your version of Outlook, follow the instructions in one of the following knowledgebase articles:
How to Add My Act! Address Book to Microsoft® Outlook 2003, Outlook 2002 (XP) or Outlook 2000
Answer ID How to Add My ACT! Address Book to Microsoft® Outlook® 2003, Outlook 2002 (XP) or Outlook 2000
How To Add My Act! Address Book To Microsoft® Outlook 2007
Answer ID How To Add My Act! Address Book To Microsoft® Outlook® 2007
How to add my Act! address book to Microsoft Outlook 2010, 2013, or 2016
Answer ID How to add my Act! address book to Microsoft Outlook 2010 and later - After adding the Act! address book, restart Outlook if not prompted to do so
- Verify that the Add-ins are available. If still unavailable, proceed to the next section
The Act! Add-in is disabled or not configured to load in Outlook
If the Act! Add-in is disabled or is set to inactive, the Add-ins options will not be available. Follow the steps below depending on your version of Outlook:
Outlook 2010, Outlook 2013, or Outlook 2016
The Act! add-in is being blocked by Outlook Macro Security
This can occur if Outlook Macro Security is blocking the Act! add-in. Refer to the steps that apply for your version of Outlook:
Outlook 2010, Outlook 2013, Outlook 2016
Internet Zone setting for Outlook 2003 (v16 and earlier only)
This issue may be caused by the default Internet Zone setting in Outlook 2002 and 2003 being set to Restricted. To change this setting, follow these steps:
- In Outlook, click Tools > Options, then select the Security tab
- In the Internet Zone section, change the zone to Internet, then click OK
- Restart Outlook and test
Corrupted Outlook toolbar customizations
This issue can occur if your Outlook toolbar customizations have become corrupt and need to be reset. Follow the steps that apply to your version of Outlook:
Outlook 2010, Outlook 2013, or Outlook 2016
The Act! add-in is being blocked by a Third-Party Add-In
To determine if any other third-party add-ins are causing the issue, you can temporarily disable them to test. Refer to the steps which apply to your version of Outlook
Outlook 2010, Outlook 2013, or Outlook 2016
Note: The Team Viewer Add-In for Outlook also uses mscoree.dll and when enabled can cause the Act! Add-Ins to not load.
Return to Top
Windows Registry settings for Act! add-in load behavior
Use these steps to verify the Load Behavior is set at the correct value for the Act! add-in to load correctly.
- Close Act! and Outlook.
- Click Start and select Run.
- The Run dialog box appears. In the Select field, type regedit.
Caution: We strongly recommend that you back up the system registry before making any changes. Incorrect changes to the registry could result in permanent data loss or corrupted files. Please make sure you modify only the keys specified. For detailed information on backing up the Windows Registry, click the link below:
Answer ID How to back up the Windows Registry
- Browse in the registry to the following keys:
- 32-bit operating systems: HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\
ACTOutlookAddin.Connect.
64-bit operating systems: HKEY_LOCAL_MACHINE\Software\WOW6432node\Microsoft\Office\Outlook\
Addins\ACTOutlookAddin.Connect. - All systems: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\ACTOutlookAddin.Connect.
- 32-bit operating systems: HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins\
- Close the Registry and restart your computer.
- Open Outlook and test.
The Act! address book was not properly added to the Windows Registry
After you have followed the steps above and the error still persist, please apply the additional steps below:
- Close Act! and Outlook.
- Click the Windows Start button and select Run.
- The Run dialog box appears, type regedit.
Caution: We strongly recommend that you back up the system registry before making any changes. Incorrect changes to the registry could result in permanent data loss or corrupted files. Please make sure you modify only the keys specified. For detailed information on backing up the Windows Registry, click the link below:
Answer ID How to back up the Windows Registry
- Browse to HKEY_CURRENT_USER\Software\ACT\OutlookAddressBooks.
- Individually right-click on folders 1, 2, and 3 and select Delete.
- Close the registry
- Click Here for instructions on to add the Act! Address back into Outlook.
The Act! plug-in files are damaged
You can attempt to replace the Act! plug-in files for Outlook Integration to attempt resolution:
- Close Outlook and Act!
- Open My Computer and browse to one of the following locations dpending on your operating system type:
- 64-bit: C:\Windows\SysWOW64
- 32-bit: C:\Windows\System32
- Click Tools and select Folder Options. The Folder Options dialog box appears. Click the View tab and activate Show hidden files and folders and clear the check box beside Hide extensions for known file types.
- Click OK for the changes to apply. Locate and rename the following files:
- ActAB32.dll
Rename to ActAB32.old - Actext.dll
Rename to Actext.32.old - Act9AB32.dll
Rename to Act9AB32.old - Act9ext.dll
Rename to Act9Ext.old
- ActAB32.dll
- Insert the Act! installation CD into the CD-Rom drive and click Browse CD or access the Act! download media.
- Browse to one of the following locations, depending on which version of Act! you're using:
Pro: ACTSTD\System32
Premium: ACTWG\System32
Premium (access via web): ACTForWeb\System32 - Right click on the Act9AB32.dll and the Act9Ext.dll and select Copy.
- Browse to C:/Windows/System32 folder and click the Edit menu and select Paste. Close My Computer.
- Launch Outlook and add the Act! Address Book.
Damaged Add-in Registry Entries
The following steps have been known to resolve this issue. Please use the following steps to attempt resolution:
Damaged Act! add-in Windows Registry entries
Damaged Microsoft Outlook Application (Outlook 2007 and earlier only)
If the steps above do not resolve the issue, it is likely that your installation of Outlook is damaged. To resolve this, you may need to recreate the Outlook Extend.dat file, attempt to repair Outlook or reinstall the Outlook application.
To recreate the Extend.dat file:
- Close Outlook
- Open Windows Explorer and browse to the appropriate location for your operating system:
- Windows Vista and later: C:\Users\%username%\AppData\Local\Microsoft\Outlook
- Windows XP/Server 2003: C:\Documents and Settings\%username%\Local Settings\Application data\Microsoft\Outlook
- Delete the Extend.dat file
- Reopen Outlook to recreate the file
Microsoft Office 2010, 2013, and 2016 applications need to be repaired by accessing the Add/Remove Programs (Programs and features if using Windows vista or later) section from the Control Panel. Select Microsoft Office 2010, 2013, or 2016 from the list, Click Change, then select the Repair option.
Microsoft Office 2007 come with an Office Diagnostics feature that is found under the Help menu. You do not need your Office installation CD to run this
All Microsoft Office 2002 and 2003 applications come with a Detect and Repair feature which can be accessed under the Help menu. Your Microsoft Office installation CD is required to complete the process. When performing the Detect and Repair DO NOT enable the checkbox “Discard my customized settings and restore default settings”, as doing so will result in the need to uninstall and reinstall Act!.
For additional details on repair or reinstalling Microsoft Outlook, contact Microsoft for assistance.
In the event that Outlook needs to be uninstalled to resolve the issue, Act! will need to be reinstalled after Outlook has been reinstalled. For more information about uninstalling or installing Act!, refer to the following articles:
How do I uninstall Act!?
Answer ID How do I uninstall Act!?
How do I install Act!?
Answer ID How do I install Act!?
Return to Top