Symptom:
You are installing Act! and receive the error:
"Act! pre-requisite has encountered a problem and needs to close."
Product:
Product Family: Act!
Product: Act! Pro, Act! Premium
There is more than one possible cause for this issue.
Cause:
You are installing on a Windows 10 computer, version 1803 or above (you can check the version in Windows 10 by going to Start > Settings > System > About) and "Beta: Use Unicode UTF-8 for worldwide language support" (see below) is enabled.
Solution:
On Windows 10 version 1803 and above, Microsoft introduced a beta option in the Region Settings which causes this error whenever it is enabled. The reason behind this is that the SQL master database fails to create successfully causing the SQL installation to error. This will also result in the error "Cannot recover the master database. SQL Server is unable to run. Restore master from a full backup, repair it or rebuild it..." appearing in Event Viewer (Start > Type Event Viewer > Windows Logs > Application) as seen in the screenshot below:

BEFORE attempting to reinstall Act!, please follow the steps below to resolve the issue:
Cause:
You are installing on a Windows 8, Windows 8.1, or Windows 10 computer and Microsoft .NET Framework 3.5 is not currently enabled.
Solution:
Note: Swiftpage does not provide support for Microsoft products. If you require assistance with Microsoft .NET, contact Microsoft or an IT professional for assitance. You can resolve this issue by installing Microsoft .NET Framework 3.5. For more information, refer to the following Microsoft documentation:
Installing the .NET Framework 3.5 on Windows 8, Windows 8.1, and Windows 10
Cause:
Windows Update is turned off and your computer is missing an update that will allow Microsoft SQL Server to install.
Solution:
Cause:
The machine requires a reboot.
Solution:
Cause:
This issue can occur if you are installing Act! v17.1 or later onto a computer which does not support Microsoft SQL Server 2014, and has never had Act! installed to it. For information about versions of Windows compatible with Microsoft SQL Server 2014, refer to the following Microsoft documentation:
Hardware and Software Requirements for Installing SQL Server 2014
For information about using Act! v17.1 and later with Microsoft SQL Server, refer to the following knowledgebase article:
Frequently Asked Questions about using Act! v17.1 and later with Microsoft SQL Server 2014
Solution:
If you are using a version of Windows that is not supported for use with Microsoft SQL Server 2014, and you do not already have a Microsoft SQL Server 2008 R2 (ACT7) instance, you can install Act! v17.0 (Download: Act! Pro, Act! Premium, Act! Premium access via web), which will install the Microsoft SQL Server 2008 R2 (ACT7) instance. Then you can upgrade to Act! v17.1 or later. The applicable update can be downloaded by going to our download center, then selecting the release that applies to you.
Alternatively, you can manually create the Microsoft SQL Server 2008 R2 instance prior to installing Act! v17.1 or later. If you are using a machine that Microsoft SQL Server 2014 does not support, and you are upgrading from an Act! version 2010 or older, you must uninstall the existing Microsoft SQL Server (ACT7) instance from the Control Panel prior to manually creating the Microsoft SQL Server 2008 R2 (ACT7) instance, and then installing Act! v17.1 or later. For information on manually creating the Microsoft SQL Server 2008 R2 (ACT7) instance, refer to the following knowledgebase article:
How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance
Answer ID How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance
Cause:
The ACT7 instance of Microsoft® SQL Server is not started.
Solution:
Follow the steps below to ensure the ACT7 instance of SQL Server is started:
If the service is already listed as started, or you do not see the service listed at all, then continue to the next section below.
Cause:
This can occur if the installation folder PreReq is damaged.
Solution:
This issue can be resolved by renaming the PreReq folder.
Note: If you are installing Act! from a disk, please contact Swiftpage for a download link for your version of Act!.
To rename the PreReq installation folder:
If this does not resolve the issue, delete the existing installation folder for Act! and download the files again. Extract and attempt the installation.
Cause:
The Pre-requisite checker process is not running properly.
Solution:
Using the following steps to bypass stop the pre-requisite checker:
Note: When the installation completes you may need to manually install the ACT7 instance of Microsoft® SQL Server®. For instructions, please see the following article:
Title: How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance
Answer ID: How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance
You are installing Act! and receive the error:
"Act! pre-requisite has encountered a problem and needs to close."
Product:
Product Family: Act!
Product: Act! Pro, Act! Premium
There is more than one possible cause for this issue.
Cause:
You are installing on a Windows 10 computer, version 1803 or above (you can check the version in Windows 10 by going to Start > Settings > System > About) and "Beta: Use Unicode UTF-8 for worldwide language support" (see below) is enabled.
Solution:
On Windows 10 version 1803 and above, Microsoft introduced a beta option in the Region Settings which causes this error whenever it is enabled. The reason behind this is that the SQL master database fails to create successfully causing the SQL installation to error. This will also result in the error "Cannot recover the master database. SQL Server is unable to run. Restore master from a full backup, repair it or rebuild it..." appearing in Event Viewer (Start > Type Event Viewer > Windows Logs > Application) as seen in the screenshot below:

BEFORE attempting to reinstall Act!, please follow the steps below to resolve the issue:
-
UNTICK the "Beta: Use Unicode UTF-8 for worldwide language support" option. To do this, go to
Start > Type Control Panel > Region (in large or small icons view) > Administrative > Change System Locale
- Check if Act! has been installed by going to Start > Type Control Panel > Programs and Features (in large or small icons view). If Act! DOES appear in the list, uninstall it.
- Uninstall the ACT7 instance. For assistance in doing this, please see the article below:
How to uninstall the ACT7 instance from Microsoft SQL Server 2014
Cause:
You are installing on a Windows 8, Windows 8.1, or Windows 10 computer and Microsoft .NET Framework 3.5 is not currently enabled.
Solution:
Note: Swiftpage does not provide support for Microsoft products. If you require assistance with Microsoft .NET, contact Microsoft or an IT professional for assitance. You can resolve this issue by installing Microsoft .NET Framework 3.5. For more information, refer to the following Microsoft documentation:
Installing the .NET Framework 3.5 on Windows 8, Windows 8.1, and Windows 10
Cause:
Windows Update is turned off and your computer is missing an update that will allow Microsoft SQL Server to install.
Solution:
- Ensure Windows Update is turned on and that all updates are installed. For more information about Windows Update, refer to the following Microsoft documentation:
How to configure and use Automatic Updates in Windows
- Reboot your computer
- Attempt to install Act! again
Cause:
The machine requires a reboot.
Solution:
- Reboot your computer
- Attempt installation again
Cause:
This issue can occur if you are installing Act! v17.1 or later onto a computer which does not support Microsoft SQL Server 2014, and has never had Act! installed to it. For information about versions of Windows compatible with Microsoft SQL Server 2014, refer to the following Microsoft documentation:
Hardware and Software Requirements for Installing SQL Server 2014
For information about using Act! v17.1 and later with Microsoft SQL Server, refer to the following knowledgebase article:
Frequently Asked Questions about using Act! v17.1 and later with Microsoft SQL Server 2014
Solution:
If you are using a version of Windows that is not supported for use with Microsoft SQL Server 2014, and you do not already have a Microsoft SQL Server 2008 R2 (ACT7) instance, you can install Act! v17.0 (Download: Act! Pro, Act! Premium, Act! Premium access via web), which will install the Microsoft SQL Server 2008 R2 (ACT7) instance. Then you can upgrade to Act! v17.1 or later. The applicable update can be downloaded by going to our download center, then selecting the release that applies to you.
Alternatively, you can manually create the Microsoft SQL Server 2008 R2 instance prior to installing Act! v17.1 or later. If you are using a machine that Microsoft SQL Server 2014 does not support, and you are upgrading from an Act! version 2010 or older, you must uninstall the existing Microsoft SQL Server (ACT7) instance from the Control Panel prior to manually creating the Microsoft SQL Server 2008 R2 (ACT7) instance, and then installing Act! v17.1 or later. For information on manually creating the Microsoft SQL Server 2008 R2 (ACT7) instance, refer to the following knowledgebase article:
How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance
Answer ID How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance
Cause:
The ACT7 instance of Microsoft® SQL Server is not started.
Solution:
Follow the steps below to ensure the ACT7 instance of SQL Server is started:
- Click your Windows Start button, either click Run or go to the Search box, and type services.msc, and click OK.
- Scroll down the list of services until you find SQL Server (ACT7)
- Under "Status", check to see if it says "Started". If you do not see "Started" under the status, right-click on the SQL Server (ACT7) service and select Start.
If the service is already listed as started, or you do not see the service listed at all, then continue to the next section below.
Cause:
This can occur if the installation folder PreReq is damaged.
Solution:
This issue can be resolved by renaming the PreReq folder.
Note: If you are installing Act! from a disk, please contact Swiftpage for a download link for your version of Act!.
To rename the PreReq installation folder:
- Browse to the Act! installation folder. Default location will be C:\ACT_Pro_(Version)
or ACT_Premium_(Version) (may vary depending on version). - Open the Dependencies folder.
- Rename the folder PreReq to "PreReqOLD"
- Run the installation again by double-clicking the setup.exe file in main installation directory.
If this does not resolve the issue, delete the existing installation folder for Act! and download the files again. Extract and attempt the installation.
Cause:
The Pre-requisite checker process is not running properly.
Solution:
Using the following steps to bypass stop the pre-requisite checker:
- Start the installation of Act!
- When the error comes up, do not click "OK".
- On your keyboard press Ctrl + Shift + Esc.
- Select Task Manager.
- Click on the Processes tab.
- Select Prereq.exe and click End process.
- The Act! installation will continue.
Note: When the installation completes you may need to manually install the ACT7 instance of Microsoft® SQL Server®. For instructions, please see the following article:
Title: How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance
Answer ID: How to Manually Create the Microsoft® SQL Server® 2008 R2 (Express Edition) ACT7 Instance