You have upgraded your Sage ACT! database to Sage ACT! 2013 and find that when you select the Edit Mode checkbox in the Contact List view you receive the error: "Object reference not set to an instance of an object."
Products:
Product Family: Sage ACT!
Product: Sage ACT! Pro, Sage ACT! Premium
Version: 2013
Cause:
This issue has been reported to occur when updating a database with custom or spillover tables to Sage ACT! 2013.
Solution:
This issue can resolved by applying the batch file attached to this article to the affected database. To apply the file, follow the steps below.
Important: This file must be run on the machine that is hosting the affected database - it cannot be run on a database accessed through a network.
- Ensure you are logged into the machine as a local Administrator.
- Close Sage ACT!
- Download the 30669.BAT file from the File Attachments section near the bottom of this article. Save the file to your computer's Desktop.
- Right-click on the downloaded file from the Desktop and select Run As Administrator. If the machine is using Windows® XP or Windows Server® 2003, then just double-click it to run.
- When prompted, type in the exact name of the affected database and press Enter on your keyboard. A list of available databases on your machine will be provided.
- After several seconds, the process will complete. Press Enter on your keyboard to finish.
- Reopen your database in Sage ACT! and test.