Symptom:
When I try to use the Back Up function to create a backup of my shared Act! database, I receive the Error: “Path to datastore is invalid. The backup did not complete.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2010 and later
Cause:
This error can result due to insufficient Windows security settings on the shared folder.
Solution:
Note: This information is provided as a convenience. Swiftpage does not provide support for Windows security configuration. For additional assistance with Windows security configuration, contact Microsoft or an IT Professional.
To resolve this issue, login to the computer that is hosting the database as a Windows Administrator, then follow the steps that apply to the version of Windows below:
Windows Vista, Windows 7, Windows 8, and Windows 10
Windows Server 2012 R2
Windows Server 2008
Windows XP/Server 2003
When I try to use the Back Up function to create a backup of my shared Act! database, I receive the Error: “Path to datastore is invalid. The backup did not complete.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2010 and later
Cause:
This error can result due to insufficient Windows security settings on the shared folder.
Solution:
Note: This information is provided as a convenience. Swiftpage does not provide support for Windows security configuration. For additional assistance with Windows security configuration, contact Microsoft or an IT Professional.
To resolve this issue, login to the computer that is hosting the database as a Windows Administrator, then follow the steps that apply to the version of Windows below:
Windows Vista, Windows 7, Windows 8, and Windows 10
- Close Act!
- Windows Explorer, then right click Computer and choose Manage
- Under System Tools, expand the Shared Folders option, then click Shares
- On the right side, locate the database files folder associated with your database, then right click it and select Properties
- Select the Share Permissions tab, then click Add…
- In the Enter the object names to select (examples): field, type Everyone, then click OK
- On the Share Permissions tab, Ensure Everyone is selected, then under Permissions for Everyone, check the option for Full Control
- Click OK to apply the change and close the window
- Launch Act! and test creating a backup again
Windows Server 2012 R2
- Close Act!
- Open Server Manager and wait for all Roles and Features to be loaded
- Select Shares, then Right click your database files folder and select Properties
- Click + next to Permissions, then click Customize Permissions
- Click the Share tab, select Everyone, then click Edit
- Check the box for Full Control, then click OK three times to save and close the screens
- Launch Act! and test creating a backup again
Windows Server 2008
- Close Act!
- Open Server manager, then select Roles
- Select File Services
- Select Share and Storage Management
- Right-click your database files folder, then select Properties
- Click the Share Permissions tab, then click Share Permissions
- Select Everyone and check the box for Full Control
- Click OK twice to save and close screens
- Launch Act! and test creating a backup again
Windows XP/Server 2003
- Close Act!
- Right-click the My Computer icon, then select Manage
- Under System Tools, expand the Shared Folders option, then click Shares
- On the right side, locate the database files folder associated with your database, then right click it and select Properties
- Select the Share Permissions tab, then click Add…
- In the Enter the object names to select (examples): field, type Everyone, then click OK
- On the Share Permissions tab, Ensure Everyone is selected, then under Permissions for Everyone, check the option for Full Control
- Click OK to apply the change and close the window
- Launch Act! and test creating a backup again