Symptom:
When attempting to edit an Act! template using Microsoft Word, you receive the error:
"Unable to cast COM object of type 'Word.ApplicationClass' to interface type 'Word._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{00020970-0000-0000-C000-000000000046}' failed due to the following error: RPC server is unavailable."
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2012 and later
Environment:
Third Party: Microsoft Word
Cause:
This can occur due to the Microsoft Office global template being damaged
Solution:
Note: Prior to following these steps, it is necessary to ensure that Windows is configured to show hidden files and folders and show file extensions for known file types. For more information, refer to the following knowledgebase article:
How to configure Windows to show hidden files and folders and show file extensions for known file types
Answer ID How to configure Windows to show hidden files and folders and/or show file extensions for known file types
You may be able to resolve this issue by renaming the Normal.dot (Office 2003) or Normal.dotm (Office 2007 and later) files and forcing Word to recreate them. Before proceeding with these steps, ensure that Word, Outlook, and Act! are all closed. Follow the steps below:
Related Information:
When attempting to edit an Act! template using Microsoft Word, you receive the error:
"Unable to cast COM object of type 'Word.ApplicationClass' to interface type 'Word._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{00020970-0000-0000-C000-000000000046}' failed due to the following error: RPC server is unavailable."
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2012 and later
Environment:
Third Party: Microsoft Word
Cause:
This can occur due to the Microsoft Office global template being damaged
Solution:
Note: Prior to following these steps, it is necessary to ensure that Windows is configured to show hidden files and folders and show file extensions for known file types. For more information, refer to the following knowledgebase article:
How to configure Windows to show hidden files and folders and show file extensions for known file types
Answer ID How to configure Windows to show hidden files and folders and/or show file extensions for known file types
You may be able to resolve this issue by renaming the Normal.dot (Office 2003) or Normal.dotm (Office 2007 and later) files and forcing Word to recreate them. Before proceeding with these steps, ensure that Word, Outlook, and Act! are all closed. Follow the steps below:
- Depending on your version of Windows, browse to one of the following locations:
- Windows Vista and later: C:\Users\[Your Windows Username]\AppData\Roaming\Microsoft\Templates
- Server 2003 and Windows XP: C:\Documents and Settings\[Your Windows Username]\Application Data\Microsoft\Templates
- In the Templates folder, rename any Normal.dot or Normal.dotm files to Normal.old, then close the Windows Explorer window
- Launch Microsoft Word to force Word to recreate the renamed files, then exit Word
- Navigate to one of the following locations, depending on your operating system (OS) and version of Act!:
64-bit OS
- Act! Pro or Act! Premium: C:\Program Files (x86)\ACT\Act for Windows
- Act! Premium (access via web): C:\Program Files (x86)\ACT\Act for Web
32-bit OS
- Act Pro or Act! Premium: C:\Program Files\ACT\Act for Windows
- Act! Premium (access via web): C:\Program Files\ACT\Act for Web
- Act! Pro or Act! Premium: C:\Program Files (x86)\ACT\Act for Windows
- Locate the following files:
- Redemption.dll
- regsvr32.exe
- Drag and drop Redemption.dll on top of regsvr32.exe
- When the prompt appears to let you know that it has registered successfully, click OK
- Open Act! and test editing a template again
Related Information:
-
Title: Error: "RPC Server not available." When Attempting to Create a Quote Using Microsoft® Word
Answer ID: Error: "RPC Server not available." When Attempting to Create a Quote Using Microsoft® Word