Symptom:
When attempting to open a database in Sage ACT!, you receive the following error:
"Could not allocate space for object 'table name' in database 'database name' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup."
Product:
Product Family: Sage ACT!
Product: Sage ACT! Pro, Sage ACT! Premium
Environment:
Engine: Microsoft SQL Server
Cause:
This is caused by reaching the database size limit when using the Express Edition of Microsoft SQL Server. See below for the size limits for each version:
Solution:
Verify that Sage ACT! is using Microsoft SQL Server Express Edition:
If using Microsoft SQL Server Express Edition, use the following steps to upgrade the ACT7 instance to Microsoft SQL Server Standard Edition:
Note: If you do not own a license for Microsoft SQL Server Standard, you will need to obtain one from Microsoft before following the steps in this article.
When attempting to open a database in Sage ACT!, you receive the following error:
"Could not allocate space for object 'table name' in database 'database name' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup."
Product:
Product Family: Sage ACT!
Product: Sage ACT! Pro, Sage ACT! Premium
Environment:
Engine: Microsoft SQL Server
Cause:
This is caused by reaching the database size limit when using the Express Edition of Microsoft SQL Server. See below for the size limits for each version:
- Microsoft SQL Server 2005 Express Edition: 4GB
- Microsoft SQL Server 2008 R2 Express Edition: 10GB
Solution:
Verify that Sage ACT! is using Microsoft SQL Server Express Edition:
-
Title: To check the local SQL Server instance properties for ACT!
Answer ID: To check the local SQL Server instance properties for ACT!
If using Microsoft SQL Server Express Edition, use the following steps to upgrade the ACT7 instance to Microsoft SQL Server Standard Edition:
Note: If you do not own a license for Microsoft SQL Server Standard, you will need to obtain one from Microsoft before following the steps in this article.
- Uninstall Microsoft SQL Server (Express Edition) ACT7 instance
-
Title: How to Uninstall the Microsoft® SQL Server® 2005 ACT7 Instance
Answer ID: How to Uninstall the Microsoft® SQL Server® 2005 ACT7 Instance-
Title: How to Uninstall the Sage ACT! ACT7 Instance from Microsoft® SQL Server® 2008 R2
Answer ID: How to Uninstall the ACT7 Instance from Microsoft® SQL Server® 2008 R2 - Install Microsoft SQL Server (Standard Edition) ACT7 instance
-
Title: How to Manually Create the Microsoft® SQL Server® 2005 (Standard Edition) ACT7 Instance
Answer ID: How to Manually Create the Microsoft® SQL Server® 2005 (Standard Edition) ACT7 Instance-
Title: How to Manually Create the Microsoft® SQL Server® 2008 R2 (Standard Edition) ACT7 Instance
Answer ID: How to Manually Create the Microsoft® SQL Server® 2008 R2 (Standard Edition) ACT7 Instance - Attempt to open your database