Symptom:
When I try to add a new contact, I receive the Error: “Cannot insert the value NULL into column ‘AEM_OPTOUT’, table ‘[Databasename].dbo.TBL_CONTACT’; column does not allow nulls. INSERT fails. The statement has been terminated.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: v18.1 and later
Cause:
This error can occur if you updated your software, but the database did not completely update to the new version for the software.
Solution:
When I try to add a new contact, I receive the Error: “Cannot insert the value NULL into column ‘AEM_OPTOUT’, table ‘[Databasename].dbo.TBL_CONTACT’; column does not allow nulls. INSERT fails. The statement has been terminated.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: v18.1 and later
Cause:
This error can occur if you updated your software, but the database did not completely update to the new version for the software.
Solution:
- Re-run the database schema update script by following the steps in the following article:
How to manually run the database schema update script in Act!
Answer ID How to manually run the database schema update script in Act!
- Open Act! and test creating a contact