Symptom: I am having trouble accessing my database, and when I look in Act! Diagnostics, it shows a status of RECOVERY_PENDING.
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2011 and later
Environment:
Third Party: Microsoft SQL Server
Cause:
There are a few reasons why this error might occur. The first is that the customer could be using third party encryption software on the location where the database is being held. make sure that the customer discusses this with their IT support to verify that they are not using third party encryption software. If they are, this will need to be disabled for the Act! database location.
This can also occur after restarting the computer due to a system crash, if the computer unexpectedly shut down while the database files were being read by the system, or if the database was improperly copied or moved to another location or computer.
Solution:
Restarting Microsoft SQL Server
- Stop and then restart the Microsoft SQL Server ACT7 instance. For information on how to do this, refer to the following knowledge base article
How to stop or start the Microsoft SQL Server (ACT7) instance
Answer ID How to stop or start the Microsoft SQL Server (ACT7) instance
- Attempt to access your database again
Use Microsoft SQL Server Management Studio to run a query
If you have Microsoft SQL Server Management Studio installed, you may be able to resolve this by running a query
Note: This information is provided as a convenience. Swiftpage does not provide support for Microsoft products. If you require assistance with these steps, or with installing and setting up Microsoft SQL Server Management studio, contact Microsoft or an IT Professional for help.
- Expand the databases in SQL Server Management Studio
- Press Ctrl + N to open a new SQL query window
- Type the code below, replacing every instance of DatabaseName with the name of your database:
Use [master]
EXEC sp_resetstatus DatabaseName
ALTER DATABASE DatabaseName SET EMERGENCY DBCC checkdb(DatabaseName)
ALTER DATABASE DatabaseName SET SINGLE_USER WITH ROLLBACK IMMEDIATE
DBCC CheckDB(DatabaseName,REPAIR_ALLOW_DATA_LOSS)
ALTER DATABASE DatabaseName SET MULTI_USER
EXEC sp_resetstatus DatabaseName - Attempt to access the database again
Note: If still unable to access the database, and if the database is still listed as RECOVERY_PENDING, refer to the following knowledgebase article:
Error: "Cannot Access Specified Database..." and the Database is Listed as SUSPECT or RECOVERY in the ACT! Diagnostics Utility
Answer ID Error: "Cannot access specified database..." and the database is listed as SUSPECT or RECOVERY in the Act! Diagnostics Utility.