Symptom: I am attempting to write an e-mail in Act! with Microsoft Outlook configured as my default email client and I receive the Error: "Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass' to interface type 'Microsoft.Office.Interop.Outlook._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{00063001-0000-0000-C000-000000000046}' failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))."
Product Details:
Product Family: Act!
Product: Act! Premium
Version: v18
Environment:
OS: Windows 10
Third Party: Microsoft Outlook
Cause:
This can occur if there was a trial version of Microsoft Office 2016 installed on the computer, but you downgraded to a previous version of Office.
Solution:
This issue can be resolved by deleting an invalid registry key left over from the higher version of Office. Follow the steps below that pertain to your scenario:
Important Note: It is strongly recommended that you create a backup of your Windows registry before proceeding with the steps below. For information on creating registry backups, refer to the following Microsoft documentation:
How to back up and restore the registry in Windows
If you downgraded from Office 2010 to Office 2007
If you downgraded from Office 2013 to Office 2010 or 2007
If you downgraded from Office 2016 to Office 2013, 2010, or 2007
Product Details:
Product Family: Act!
Product: Act! Premium
Version: v18
Environment:
OS: Windows 10
Third Party: Microsoft Outlook
Cause:
This can occur if there was a trial version of Microsoft Office 2016 installed on the computer, but you downgraded to a previous version of Office.
Solution:
This issue can be resolved by deleting an invalid registry key left over from the higher version of Office. Follow the steps below that pertain to your scenario:
Important Note: It is strongly recommended that you create a backup of your Windows registry before proceeding with the steps below. For information on creating registry backups, refer to the following Microsoft documentation:
How to back up and restore the registry in Windows
If you downgraded from Office 2010 to Office 2007
- Close Act! and all Office applications (Outlook, Word, Excel®).
- Click your Windows® Start button, either click Run or go to the Search box on the Start Menu, and type regedit. The Windows registry editor opens.
- Navigate to the following key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.4
- Delete the 9.4 key.
- Close the registry editor.
- Reopen Outlook, reopen Act! then click on a contact's email address to test.
If you downgraded from Office 2013 to Office 2010 or 2007
- Close Act! and all Office applications (Outlook, Word, Excel®).
- Click your Windows Start button, either click Run or go to the Search box on the Start Menu, and type regedit. The Windows registry editor opens.
- Navigate to the following key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.5
- Delete the 9.5 key.
- Close the registry editor.
- Reopen Outlook, reopen Act! then click on a contact's email address to test.
If you downgraded from Office 2016 to Office 2013, 2010, or 2007
- Close Act! and all Office applications (Outlook, Word, Excel®).
- Click your Windows Start button, either click Run or go to the Search box on the Start Menu, and type regedit. The Windows registry editor opens.
- Navigate to the following key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.6
- Delete the 9.6 key.
- Close the registry editor.
- Reopen Outlook, reopen Act! then click on a contact's email address to test.