Symptom:
When I try to unpack a remote database or restore a database backup, I receive the Error: “The file ‘C:\[file path]\[databasename].ADF’ is compressed but does not reside in a read-only database or file group. The file must be decompressed. Could not open File Control Block (FCB) for invalid file ID 2 in database ‘[databasename]’. Verify the file location. Execute DBCC CHECKDB. Could not open new database ‘[databasename]’. CREATE DATABASE is aborted.
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2005 and later
Cause:
This error can occur if the drive you are trying to restore the database backup or unpack the remote database to is being compressed by Windows using NTFS File Compression. For more information on NTFS Compression, refer to the following Microsoft documentation:
Best practices for NTFS compression in Windows
Solution:
Note: This information is provided as a convenience. Swiftpage does not provide support for Microsoft products. For additional assistance, contact Microsoft or an IT Professional.
To resolve this, refer to the steps below:
When I try to unpack a remote database or restore a database backup, I receive the Error: “The file ‘C:\[file path]\[databasename].ADF’ is compressed but does not reside in a read-only database or file group. The file must be decompressed. Could not open File Control Block (FCB) for invalid file ID 2 in database ‘[databasename]’. Verify the file location. Execute DBCC CHECKDB. Could not open new database ‘[databasename]’. CREATE DATABASE is aborted.
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2005 and later
Cause:
This error can occur if the drive you are trying to restore the database backup or unpack the remote database to is being compressed by Windows using NTFS File Compression. For more information on NTFS Compression, refer to the following Microsoft documentation:
Best practices for NTFS compression in Windows
Solution:
Note: This information is provided as a convenience. Swiftpage does not provide support for Microsoft products. For additional assistance, contact Microsoft or an IT Professional.
To resolve this, refer to the steps below:
- Open a Windows Explorer Window and navigate to the root of the drive referenced in the error you received
- Right-click the first folder referenced in the file path from the error message, then select Properties
- In the General tab, under Attributes, click Advanced…
- Disable the option to Compress contents to save disk space, then click OK, and then click Apply
- Choose the option to Apply changes to this folder, subfolder and files
- Click OK
- Attempt to restore the backup or unpack the remote to test