Symptom:
When I try to create a new remote database or synchronize an existing remote database, I receive the Error: “The SQL Database instance is unavailable. Contact your administrator for assistance.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2010 and later
Cause:
This issue can occur as a result of Microsoft SQL Server protocols being disabled on the publisher or remote machines. In some cases, it may also occur if the computer name of the computer hosting the remote database has changed, or if there are issues with Act! accessing the ACT7 SQL Server instance.
Solution:
Important Note: If you are are an Act! Premium Cloud subscriber and you are receiving this error while trying to synchronize an offline client, refer to the following knowledgebase article to confirm that the connection information is correct:
Error: "Act! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that Network sync service is running..." when attempting to synchronize an Act! Premium Cloud remote database
Disabled SQL Server Protocols
Ensure that the Named Pipes and TCP/IP Protocols are enabled using the steps below:
If the protocols are already enabled properly, you may be able to resolve the issue by detaching and reattaching your database to the SQL Server (ACT7) Instance.
If the computer name of the computer hosting the remote database has changed, this error may occur when attempting to synchronize. Additional steps need to be completed from the computer that is hosting the Publisher database in order to retain synchronization.
Note: The following information is provided as a convenience. Swiftpage does not provide support for Microsoft Products. For additional assistance, contact Microsoft or an IT Professional.
If the above steps are unsuccessful in resolving the issue, you may need to reinstall the SQL Server (ACT7) instance. The computer you need to reinstall the SQL Server (ACT7) instance for depends on when you are receiving the error:
For information on uninstalling and reinstalling the SQL Server (ACT7) instance, refer to the knowledgebase articles below:
How to uninstall the Microsoft SQL Server (ACT7) instance
Answer ID How to uninstall the Microsoft SQL Server (ACT7) instance
How to manually create the Microsoft SQL Server (ACT7) instance
Answer ID How to manually create the Microsoft SQL Server (ACT7) instance
When I try to create a new remote database or synchronize an existing remote database, I receive the Error: “The SQL Database instance is unavailable. Contact your administrator for assistance.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2010 and later
Cause:
This issue can occur as a result of Microsoft SQL Server protocols being disabled on the publisher or remote machines. In some cases, it may also occur if the computer name of the computer hosting the remote database has changed, or if there are issues with Act! accessing the ACT7 SQL Server instance.
Solution:
Important Note: If you are are an Act! Premium Cloud subscriber and you are receiving this error while trying to synchronize an offline client, refer to the following knowledgebase article to confirm that the connection information is correct:
Error: "Act! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that Network sync service is running..." when attempting to synchronize an Act! Premium Cloud remote database
Disabled SQL Server Protocols
Ensure that the Named Pipes and TCP/IP Protocols are enabled using the steps below:
- Ensure that Act! is closed and, if the database is shared, that no one is logged into the database
- Press the Windows Key + R on your keyboard to bring up the Run dialog
- Type MMC.exe, then press Enter
- In the Console window, click File > Add/Remove Snap-in
- In the Available snap-ins list, look for and select SQL Server Configuration Manager, click the Add button, then click OK
- Under the Console Root folder, expand SQL Server Configuration Manager (Local)
- Click the triangle next to SQL Server Network Configuration to expand it
- Click Protocols for ACT7
- Locate Named Pipes in the Protocol Name Column and, if the status is set to Disabled, right-click it and choose Enable
- Click OK on the Warning notice that appears
- Locate TCP/IP in the Protocol Name Column and, if the status is set to Disabled, right-click it and choose Enable
Note: If you did not have to enable either of these, skip to the next section
- Click OK on the Warning notice that appears
- In the left-hand Panel, under SQL Server Configuration Manager (Local), click SQL Server Services
- In the center panel, right click SQL Server (ACT7), then choose Restart
- Test remote database creation or synchronization
If the protocols are already enabled properly, you may be able to resolve the issue by detaching and reattaching your database to the SQL Server (ACT7) Instance.
- Detach and reattach the database to the SQL Server (ACT7) Instance using the steps in the following knowledgebase article:
How to detach an Act! database from the Microsoft SQL Server (ACT7) instance
Answer ID How to detach an Act! database from the Microsoft SQL Server (ACT7) instance
- Test remote database creation or synchronization
If the computer name of the computer hosting the remote database has changed, this error may occur when attempting to synchronize. Additional steps need to be completed from the computer that is hosting the Publisher database in order to retain synchronization.
- Login to the Publisher database from the server and update the database location using the steps from the knowledgebase article below:
How to retain synchronization when the Publisher (main) and/or Subscriber (remote) computer names have changed
Answer ID How to retain synchronization when the Publisher (main) and/or Subscriber (remote) computer names have changed
- Attempt to synchronize to test
Note: The following information is provided as a convenience. Swiftpage does not provide support for Microsoft Products. For additional assistance, contact Microsoft or an IT Professional.
If the above steps are unsuccessful in resolving the issue, you may need to reinstall the SQL Server (ACT7) instance. The computer you need to reinstall the SQL Server (ACT7) instance for depends on when you are receiving the error:
- If you are receiving the error when attempting to create a remote database, reinstall the SQL Server (ACT7) instance on the computer with the publisher database
- If you are receiving the error when attempting to synchronize a remote database, reinstall the SQL Server (ACT7) instance on the computer with the remote database
For information on uninstalling and reinstalling the SQL Server (ACT7) instance, refer to the knowledgebase articles below:
How to uninstall the Microsoft SQL Server (ACT7) instance
Answer ID How to uninstall the Microsoft SQL Server (ACT7) instance
How to manually create the Microsoft SQL Server (ACT7) instance
Answer ID How to manually create the Microsoft SQL Server (ACT7) instance