Symptom: I am trying to synchronize my database, when I receive the Error:
"Synchronization has failed. The multi-part identifier "SRE.ROWEXCEPTIONID" could not be bound.
Sync initialization error occurred in database object PRC_SYNC_PROCESS_INITEXCEPTION - SYNC INSERT NEW MEMBER INTO TABLE!
@cSQLJOIN - IN TYPENUM IS 6
FIRST STAGE @cSQLJOIN IS INNER JOIN dbo.CTL_SYNCROW_EXCEPTION SRE ON A.CONTACTID1 = SRE.ROWID1 AND SRE.SYNCDBMAPID = @nSYNCDBMAPID AND SRE.TABLELUID = @nENTITY_TLUID
@cSQLJOIN IS INNER JOIN dbo.CTL_SYNCROW_EXCEPTION SRE ON A.CONTACTID1 = SRE.ROWID1 AND SRE.SYNCDBMAPID = @nSYNCDBMAPID AND SRE.TABLELUID = @nENTITY_TLUID
INNER JOIN dbo.CTL_SYNCDBMAP_SESSIONROW R1 ON R1.CONTACTID = A.CONTACTID1 AND R1.SYNCDBMAPID = @nSYNCDBMAPID AND R1.SESSIONID = @nNEXT_SESSIONID
INNER JOIN dbo.CTL_SYNCDBMAP_SESSIONROW R2 ON R2.CONTACTID = A.CONTACTID2 AND R2.SYNCDBMAPID = @nSYNCDBMAPID AND R2.SESSIONID = @nNEXT_SESSIONID
Contact your administrator for assistance.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2012 and later
Cause:
This can occur if the remote database has become damaged.
Solution:
Perform Database Maintenance
Note: Prior to following the steps below, it is recommended that you create backups the main database AND the remote database. For information regarding database backups, refer to the following knowledgebase article:
How to back up and restore an Act! database
Create a new Remote
If database maintenance does not work, try the steps below:
"Synchronization has failed. The multi-part identifier "SRE.ROWEXCEPTIONID" could not be bound.
Sync initialization error occurred in database object PRC_SYNC_PROCESS_INITEXCEPTION - SYNC INSERT NEW MEMBER INTO TABLE!
@cSQLJOIN - IN TYPENUM IS 6
FIRST STAGE @cSQLJOIN IS INNER JOIN dbo.CTL_SYNCROW_EXCEPTION SRE ON A.CONTACTID1 = SRE.ROWID1 AND SRE.SYNCDBMAPID = @nSYNCDBMAPID AND SRE.TABLELUID = @nENTITY_TLUID
@cSQLJOIN IS INNER JOIN dbo.CTL_SYNCROW_EXCEPTION SRE ON A.CONTACTID1 = SRE.ROWID1 AND SRE.SYNCDBMAPID = @nSYNCDBMAPID AND SRE.TABLELUID = @nENTITY_TLUID
INNER JOIN dbo.CTL_SYNCDBMAP_SESSIONROW R1 ON R1.CONTACTID = A.CONTACTID1 AND R1.SYNCDBMAPID = @nSYNCDBMAPID AND R1.SESSIONID = @nNEXT_SESSIONID
INNER JOIN dbo.CTL_SYNCDBMAP_SESSIONROW R2 ON R2.CONTACTID = A.CONTACTID2 AND R2.SYNCDBMAPID = @nSYNCDBMAPID AND R2.SESSIONID = @nNEXT_SESSIONID
Contact your administrator for assistance.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2012 and later
Cause:
This can occur if the remote database has become damaged.
Solution:
Perform Database Maintenance
Note: Prior to following the steps below, it is recommended that you create backups the main database AND the remote database. For information regarding database backups, refer to the following knowledgebase article:
How to back up and restore an Act! database
- Perform a database Check and Repair in the remote database. For instructions, refer to the following knowledgebase article:
Act! database rebuild and repair procedures
- Perform the same database Check and Repair procedure in the publisher (main) database
- Test the synchronization
Create a new Remote
If database maintenance does not work, try the steps below:
- Create and restore a new remote database to the computer receiving the error. For information on creating remote databases, refer to the following knowledgebase article:
How do I set up remote database synchronization in Act!?
- Test the synchronization