Symptom:
When attempting to open a shared database across the network, you receive the following error:
"The (Server) computer and (DatabaseName) database were found but you do not have appropriate share permissions to access the (SupplementalFilesFolder) folder on (Server) computer…"
Product:
Product Family: Act!
Version/SP: 2013 and above
Cause:
This can occur if the version of Act! on the client machine is different to that on the host machine. Check this by going to Help > About Act! on both the client and host machines. If the versions are different, refer to the following knowledgebase article to ensure both computers are using the most recent updates available:
What are the most recent updates for my version of Act!?
If both machines are using the same version, the issue can also be caused when the client machine or Windows® user name does not have permission to access files on the host machine.
Solution:
Unshare and re-share the database
Note: If User Account Control (UAC) is enabled then Act! will need to be run as an administrator. To run Act! as an administrator, right click the Act! icon and select ‘Run as administrator’.
Browse to the shared folder using the UNC path
If you can see the list of shared folders
Try to access the database supplemental files folder. If you receive an access denied message, the permissions may need to be set manually.
If you are prompted for a username and password:
If you are experiencing this error and the machine hosting the database is using a Windows Vista or later operating system, it could be the result of the Password Protected File Sharing security feature being enabled. We recommend that you communicate with your network administrator before making any modifications to this feature.
If you cannot or do not wish to disable Password Protected File sharing, you can work around it by using the following steps from the workstation experiencing the issue:
When attempting to open a shared database across the network, you receive the following error:
"The (Server) computer and (DatabaseName) database were found but you do not have appropriate share permissions to access the (SupplementalFilesFolder) folder on (Server) computer…"
Product:
Product Family: Act!
Version/SP: 2013 and above
Cause:
This can occur if the version of Act! on the client machine is different to that on the host machine. Check this by going to Help > About Act! on both the client and host machines. If the versions are different, refer to the following knowledgebase article to ensure both computers are using the most recent updates available:
What are the most recent updates for my version of Act!?
If both machines are using the same version, the issue can also be caused when the client machine or Windows® user name does not have permission to access files on the host machine.
Solution:
Unshare and re-share the database
Note: If User Account Control (UAC) is enabled then Act! will need to be run as an administrator. To run Act! as an administrator, right click the Act! icon and select ‘Run as administrator’.
- On the host machine, open Act! and log into the database as an administrative user
- Tools > Database Maintenance > uncheck Share Database > agree to any prompts
- Tools > Database Maintenance > check Share Database
- Agree to any prompts, enter your user credentials again if necessary
- Attempt to access the database from the client machine
Browse to the shared folder using the UNC path
- On a client machine, press the Windows key + R to access the Run prompt
- Type: \\
, e.g, \\server01 - Click OK or press Enter
If you can see the list of shared folders
Try to access the database supplemental files folder. If you receive an access denied message, the permissions may need to be set manually.
- From the computer hosting the shared database, launch Windows Explorer (or Computer) and navigate into the folder containing your Act! database.
- Right-click on the database supplemental files folder and select Properties from the shortcut menu. The folder Properties dialog box appears.
Windows XP and equivalents:
- On the Sharing tab, ensure that the ‘Share this folder’ option is enabled and that the user limit is sufficient to allow all desired users to share the folder. Click the Permissions button. The Permissions for the shared folder dialog box appears.
- It is recommended the user named Everyone have Full Control permissions to the shared folder. In some cases, it is necessary to add the specific names of the remote users to this Share Permissions list, to ensure that each domain user has Full Control of the shared folder.
For detailed information on adding specific domain users to the Share Permissions list, please contact your network administrator or Microsoft.
Windows Vista and above:
- On the sharing tab, click the Advanced Sharing button.
- Ensure that ‘Share this folder’ is checked and that the user limit is sufficient to allow all desired users to share the folder. Click the Permissions button. The Permissions for the shared folder dialog box appears
- It is recommended the user named Everyone have Full Control permissions to the shared folder. In some cases, it is necessary to add the specific names of the remote users to this Share Permissions list, to ensure that each domain user has Full Control of the shared folder.
For detailed information on adding specific domain users to the Share Permissions list, please contact your network administrator or Microsoft.
If you are prompted for a username and password:
If you are experiencing this error and the machine hosting the database is using a Windows Vista or later operating system, it could be the result of the Password Protected File Sharing security feature being enabled. We recommend that you communicate with your network administrator before making any modifications to this feature.
If you cannot or do not wish to disable Password Protected File sharing, you can work around it by using the following steps from the workstation experiencing the issue:
- On your keyboard, press the Windows key + R
- Type \\[servername] in the run dialog box and press Enter
Note:You may also wish to do this with the server IP address as well, as sometimes the server name will not prompt for a username and password, but the IP address will prompt for the username and password. - When prompted for the username and password, enter the Windows Administrator username and password for the server
- Check the box to remember the credentials
- Click OK
- Attempt to open the database again
- This process may need to be repeated if the client machine is rebooted