Symptom: When I try to access my database, I receive the Error: “The ‘[HOSTCOMPUTER NAME]’ computer could not be reached because the IP address ‘ ’ could not be resolved. Verifying the ‘[HOSTCOMPUTER NAME]’ computer is available on the network, that it has the correct IP address, and that Microsoft SQL Server is properly installed may resolve the issue.”
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2012 and later
Environment:
Engine: Microsoft SQL Server
Cause:
This can occur if the SQL Server (ACT7) instance or Microsoft SQL Server Browser are not started or if the information in the PAD file is no longer correct. For example, if the database was moved to a new computer or location, but you’re still trying to use the old PAD file, or if the name of the machine hosting the database has been changed.
Additionally this can occur if the database files folder does not appropriate permissions.
Solution:
Starting the SQL Server (ACT7) instance
Follow the steps below to restart the SQL Server (ACT7) instance:
Recreating the PAD file
You can make sure that the PAD file has the correct information by recreating the PAD file.
Note: If you’re using Act! in a shared multi-user environment, and other users are able to access the database, you can have one of the other users copy their PAD file and send it to you to test with before following the steps below.
Ensuring proper database permissions
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2012 and later
Environment:
Engine: Microsoft SQL Server
Cause:
This can occur if the SQL Server (ACT7) instance or Microsoft SQL Server Browser are not started or if the information in the PAD file is no longer correct. For example, if the database was moved to a new computer or location, but you’re still trying to use the old PAD file, or if the name of the machine hosting the database has been changed.
Additionally this can occur if the database files folder does not appropriate permissions.
Solution:
Starting the SQL Server (ACT7) instance
Follow the steps below to restart the SQL Server (ACT7) instance:
- Ensure you’re on the machine that has the database files stored on it
- Start the SQL Server (ACT7) instance and the Microsoft SQL Server Browser service by using the steps in the following knowledgebase article:
How to manage the Microsoft SQL Server (ACT7) instance or SQL Server Browser from the Windows Services console
- Test opening the database from the computer experiencing the error
Recreating the PAD file
You can make sure that the PAD file has the correct information by recreating the PAD file.
Note: If you’re using Act! in a shared multi-user environment, and other users are able to access the database, you can have one of the other users copy their PAD file and send it to you to test with before following the steps below.
- Ensure you’re on the machine that has the database files stored on it
- Recreate the PAD file by following the instructions in the following knowledgebase article:
How to modify or recreate an Act! database .PAD file
- Transfer a copy of the recreated PAD file to the machine receiving the error message
- Test opening the database again
Ensuring proper database permissions
- Ensure you’re on the machine that has the database files stored on it
- In Windows Explorer, browse to the location of the database
- Right-click the [databasename]-database files folder, then select properties
- Ensure that the share permissions and the security are set to give Everyone full control
- Test opening the database again from the machine receiving the error message