Symptom: When I try to schedule an activity, I get the Error: “Object reference not set to an instance of an object”
Product Details:
Product Family: Act!
Product: Act! Pro, Act!
Version: 2005 and later
Cause:
This issue can occur if your database was converted from Act! 3.x, 4.x, 5.x, or 6.x and has one or more damaged activities during the conversion to Act! version 2005 or later.
Solution:
Option 1 – Run database maintenance in Act! version 2005 or later
Option 2 – Create an archive copy and purge old information
If your previous version database has a large amount of cleared activities, it is strongly recommended that you create an archive copy of the previous version database, then purge the older activities from the working database. You can access the older information by opening the archive copy. Follow the steps below:
Product Details:
Product Family: Act!
Product: Act! Pro, Act!
Version: 2005 and later
Cause:
This issue can occur if your database was converted from Act! 3.x, 4.x, 5.x, or 6.x and has one or more damaged activities during the conversion to Act! version 2005 or later.
Solution:
Option 1 – Run database maintenance in Act! version 2005 or later
- Run database maintenance procedures found in the following knowledgebase article:
ACT! Database Rebuild and Repair Procedures
Answer ID Act! database rebuild and repair procedures
- Attempt to schedule the activity again to test
Option 2 – Create an archive copy and purge old information
If your previous version database has a large amount of cleared activities, it is strongly recommended that you create an archive copy of the previous version database, then purge the older activities from the working database. You can access the older information by opening the archive copy. Follow the steps below:
- Open your database in the previous version of Act!
- Click File > Save Copy As
- Ensure the Copy the database option is enabled, the Database Version is correct, then click the browse button. (or click OK)
- Take note of (or change) the Save In location, type a File name, then click Save to create the archived copy of the database which can be opened at a later time with the previous version of Act!
- While logged into the working database, click File > Administration > Database Maintenance
- In the Data Clean-up Tab, enable only Cleared activities older than, set the number of days to 0, then click Remove Selected Items
- When prompted to confirm the deletion, click Yes
- Once the data has been purged, scan and repair the database
- After scanning and repairing the database, compress and reindex the database
Note: For instructions on scanning, repairing, compressing, and reindexing the database, refer to the following knowledgebase article:
How To Use The Act! Data Diagnostic Tool (ACTDIAG) to Scan and Repair a Database
Answer ID How To Use The Act! Data Diagnostic Tool (ACTDIAG) to Scan and Repair a Database
- Delete the failed conversion from the new Act! version by following Option 2 in the following knowledgebase article:
How to delete an Act! database
Answer ID How to delete an Act! database
- Reconvert the database
- Test scheduling an activity to test