Symptom:
When I try to import Contact, Company, or Group records into my Act! database, I receive the Error: "Access to the path C:\ProgramData\Swiftpage ACT! LLC\[Act! version]ImportCSV.txt is denied"
Product:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: v18 and later
Environment:
OS: Windows 7 and later
Cause:
This can occur if the [Act! version]ImportCSV.txt is damaged, if the Windows user has insufficient access to this folder, or if the Windows User Account Control (UAC) feature is blocking access to this location.
Solution:
Note: Before proceeding with these steps, it is important to ensure that your Windows Explorer settings are configured to display file extensions and to show hidden files, folders, and protected operating system files. For more information, refer to the following knowledgebase article:
How to configure Windows to show hidden files and folders and show file extensions for known file types
Damaged [Act! version]ImportCSV.txt
Folder Permissions
UAC blocking access to the path
You may be able to resolve this issue using the Windows Run as administrator option or by disabling the UAC feature.
Run as Administrator
Disable User Account Control
When I try to import Contact, Company, or Group records into my Act! database, I receive the Error: "Access to the path C:\ProgramData\Swiftpage ACT! LLC\[Act! version]ImportCSV.txt is denied"
Product:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: v18 and later
Environment:
OS: Windows 7 and later
Cause:
This can occur if the [Act! version]ImportCSV.txt is damaged, if the Windows user has insufficient access to this folder, or if the Windows User Account Control (UAC) feature is blocking access to this location.
Solution:
Note: Before proceeding with these steps, it is important to ensure that your Windows Explorer settings are configured to display file extensions and to show hidden files, folders, and protected operating system files. For more information, refer to the following knowledgebase article:
How to configure Windows to show hidden files and folders and show file extensions for known file types
Damaged [Act! version]ImportCSV.txt
- Close Act!
- Browse to C:\ProgramData\Swiftpage ACT! LLC
- Rename [Act! version]ImportCSV.txt to [Act version]ImportCSV.OLD
- Open Act! and attempt to import again to test
Folder Permissions
- Close Act!
- Browse to the location path C:\ProgramData\Swiftpage ACT! LLC
- Right click Act! folder and select properties
- Add Everyone and give Full Control permissions
- Click Security tab; click Add.
- In the Enter the object names to select type in Everyone.
- Click Check Names and this will underline the everyone just typed. Click OK.
- Under Group or user names select and highlight Everyone.
- Check Full control under Allow.
- Click Apply; click OK.
- Launch Act!
- Test import
UAC blocking access to the path
You may be able to resolve this issue using the Windows Run as administrator option or by disabling the UAC feature.
Run as Administrator
- Close Act!
- Right click the Act! icon
- Select Run as administrator
- Test import
Disable User Account Control
- Close Act!
- Use the instructions in the following article to disable UAC:
-
How to Change or Disable User Account Control (UAC) in Windows® 7 & Windows Server® 2008
Answer ID How to Change or Disable User Account Control (UAC) in Windows® 7 & Windows Server® 2008
- Launch Act!
- Test import