Symptom: I am trying to synchronise my remote database but the synchronisation is hanging at "Database modifications".
Product Details:
Product Family: Act!
Product: Act! Pro, Act! Premium
Version: 2011 and later
Cause:
This error can occur due to damage in the database, or by a known issue that Microsoft has published for Microsfot SQL Server that causes checkpoint operations in Microsoft SQL Server databases to fail due to a duplicate database table row that gets inserted into the back end of the database.
Solution:
Rebuilding the database's Sync Objects
- Back up the affected database
How to back up and restore an Act! database - Ensure Act! is closed
- On your keyboard, press the Windows key + R to bring up the run dialog
- Type actdiag in the Open field, then press Enter or click OK
- Read the Act! Diagnostics Disclaimer, then click OK
- Click the Databases menu, then select Database List
- Click the gray rectangle to the left of the appropriate Database name to select the database
- Click the Actions menu, then select Database Rebuild, then Rebuild Sync Objects
- When the notice of completion appears, click OK
- Attempt to synchronise your remote database
Repairing, reindexing and rebuilding the databases
- Back up the publisher database as well as the remote database(s).
How to back up and restore an Act! database
- Follow the instructions in the below article for every database synchronising, inluding the main database:
Act! database rebuild and repair procedures
Answer ID 19642
- Attempt to synchronise your remote database(s)
Removing duplicate database table rows
- Back up the publisher database as well as the remote database(s).
How to back up and restore an Act! database
- Remove the duplicate database table rows with the following article:
Error: "Cannot insert duplicate key row in object 'sys.syscommittab' with unique index 'si_xdes_id'... error 2601" when attempting to back up, copy, repair, create a remote, or synchronize an Act! database
- Attempt to synchronise your remote database(s)