Symptom: Error “The machine hosting your API is not currently reachable. Please speak to your administrator to assist” when trying to access Act! Marketing Automation
Product Details:
Product Family: Act! Growth Suite
Tier: Premier, Ultimate
Version: v21 and above
Cause:
If a user is operating in a networked environment (e.g. the Act! database is being hosted on a server that the user is networked to) then this error can occur if the networked computer that acts as the API host is shut down, or is not hosting the API correctly.
Solution:
The first step is to make sure that the computer that hosts your API is currently switched on. In the majority of cases this will fix the issue.
Whilst we would typically recommend that the API is hosted on a server if you have one to avoid accidentally shutting it down, it may be the case that another one of your computers is acting as the API host instead. If you are not sure which of your computers hosts the API, make sure to switch on all of the computers that you have that use Act! one at a time, open up Act! on them and test Act! Marketing Automation. Once you find the computer that does not show the error message, test the networked computers as well and make sure the error message is no longer displaying.
I know which computer is my API host and it is switched on but I still get the error
In this scenario, it may be the case that the Web API service is not running on the API host computer. To check this, click on the Windows Start button, type services.msc and hit enter.
In the list of services displayed, locate Act! Web API Host.
Ensure that the status for this service is Running.
If it is not, right click on the service and choose Start.
Restart Act! and test your access to Act! Marketing Automation.
I am still getting the same error and I use the Act! Connect Link
Similar to the previous step, you will need to make sure that the Act! Connect Link service is running on the API host computer. To check this, click on the Windows Start button, type services.msc and hit enter.
In the list of services displayed, locate Act!ConnectLink.
Ensure that the status for this service is Running.
If it is not, right click on the service and choose Start.
Restart Act! and test your access to Act! Marketing Automation.
I am still getting the same error and I use the Act! Web API
It may be the case that there was a previous installation of the Connect Link on the API host computer and that this has not been fully removed. This could prevent the Web API from working correctly.
In this scenario, follow the article below to uninstall the Act! Connect Link. Please be certain that you are not using the Act! Connect Link before you uninstall it.