Symptom: While trying to log into Act! access via web over the Internet, you receive the following error message: "Error validating user. Showing a modal dialog box or form when the application is not running in UserInteractive mode is not a valid operation. Specify the ServiceNotification or DefaultDesktopOnly style to display a notification from a service application"
Product Details:
Product Family: Act!
Product: Act! access via web
Cause:
This error can occur when the Act! access via web Windows user account has been set to "User must change password at next logon." Removing this setting will fix the problem.
Solution:
When setting up Act! access via web to allow database users to access Act! across the Internet, you need to create a Windows user account for ASP.NET impersonation on the server hosting Act! access via web. These user credentials are then added into the setup when you configure your Act! database for Internet access.
The error described above can occur when there is a problem with the impersonation account. For more information on configuring the impersonation account, please refer to to the "Creating a Windows User Account for ASP.NET Impersonation" section of the Administrators Guide on page 5 for more information.
Act! v22 access via web Administrator's Guide
The error message will appear when any Act! user tries to log into the database across the Internet:
In order to correct this error, you will need to log into Windows as an administrator on the computer hosting Act! access via web. Once you have done this, follow the steps below:
1. Open Local Users and Groups. Specific steps to do this depend on your
operating system, but typically can be found simply by clicking the Start menu, then typing Local Users and Groups.
2. Expand Local Users and Groups, and then click the Users folder.
3. Locate the Impersonation User. This user is often named APFW to easily identify it, but it does not have to be. You should check this with the person who set up the user initially.
4. Once you have located the user, right-click it and choose Properties.
5. Under the General tab, locate the option User must change password at next logon. Make sure this option is unchecked.
6. Click Apply then OK.
7. Test logging into the online database again.